読者です 読者をやめる 読者になる 読者になる

文系男子が日和るIT開発~IT知識なしで飛び込んだIT企業

文系男子だからIT企業に就職するなんて考えてもみませんでしたが、日和ながら日々くらいついています。

(Eclipse)要求が完了できません。

Eclipseプラグインのインストール中に
「要求が完了できません。」

と出て、インストールが失敗。

 

Cannot complete the install because of a conflicting dependency.
  Software being installed: Android Development Tools 23.0.4.1468518 (com.android.ide.eclipse.adt.feature.feature.group 23.0.4.1468518)
  Software currently installed: Eclipse IDE for Java EE Developers 1.3.2.20110218-0812 (epp.package.jee 1.3.2.20110218-0812)
  Only one of the following can be installed at once:
    EMF XML/XMI Persistence 2.5.0.v20100521-1846 (org.eclipse.emf.ecore.xmi 2.5.0.v20100521-1846)
    EMF XML/XMI Persistence 2.9.1.v20130827-0309 (org.eclipse.emf.ecore.xmi 2.9.1.v20130827-0309)
  Cannot satisfy dependency:
    From: Android Development Tools 23.0.4.1468518 (com.android.ide.eclipse.adt.feature.feature.group 23.0.4.1468518)
    To: org.eclipse.ui 3.7.0
  Cannot satisfy dependency:
    From: Eclipse IDE for Java EE Developers 1.3.2.20110218-0812 (epp.package.jee 1.3.2.20110218-0812)
    To: org.eclipse.epp.package.jee.feature.feature.group [1.3.2.20110218-0812]
  Cannot satisfy dependency:
    From: Data Tools Platform Model Base 1.8.0.v201005280400-77077CcNBGKBWJ_HWVi (org.eclipse.datatools.modelbase.feature.feature.group 1.8.0.v201005280400-77077CcNBGKBWJ_HWVi)
    To: org.eclipse.emf.feature.group 2.4.0
  Cannot satisfy dependency:
    From: Data Tools Platform Model Base 1.8.1.v20100618-77078CcNBGKBZI_FcRd (org.eclipse.datatools.modelbase.feature.feature.group 1.8.1.v20100618-77078CcNBGKBZI_FcRd)
    To: org.eclipse.emf.feature.group 2.4.0
  Cannot satisfy dependency:
    From: Data Tools Platform Model Base 1.8.2.v201010181125-77078CcNBGKBZI_FcRd (org.eclipse.datatools.modelbase.feature.feature.group 1.8.2.v201010181125-77078CcNBGKBZI_FcRd)
    To: org.eclipse.emf.feature.group 2.4.0
  Cannot satisfy dependency:
    From: Eclipse Workbench Model 0.10.1.v20120523-1955 (org.eclipse.e4.ui.model.workbench 0.10.1.v20120523-1955)
    To: bundle org.eclipse.emf.ecore.xmi [2.6.0,3.0.0)
  Cannot satisfy dependency:
    From: EMF - Eclipse Modeling Framework Core Runtime 2.6.0.v20100614-1136 (org.eclipse.emf.ecore.feature.group 2.6.0.v20100614-1136)
    To: org.eclipse.emf.ecore.xmi [2.5.0.v20100521-1846]
  Cannot satisfy dependency:
    From: EMF - Eclipse Modeling Framework Core Runtime 2.6.1.v20100914-1218 (org.eclipse.emf.ecore.feature.group 2.6.1.v20100914-1218)
    To: org.eclipse.emf.ecore.xmi [2.5.0.v20100521-1846]
  Cannot satisfy dependency:
    From: EMF - Eclipse Modeling Framework Runtime and Tools 2.6.0.v20100614-1136 (org.eclipse.emf.feature.group 2.6.0.v20100614-1136)
    To: org.eclipse.emf.ecore.feature.group [2.6.0.v20100614-1136]
  Cannot satisfy dependency:
    From: EMF - Eclipse Modeling Framework Runtime and Tools 2.6.1.v20100914-1218 (org.eclipse.emf.feature.group 2.6.1.v20100914-1218)
    To: org.eclipse.emf.ecore.feature.group [2.6.1.v20100914-1218]
  Cannot satisfy dependency:
    From: Java EE IDE Feature 1.3.2.20110218-0812 (org.eclipse.epp.package.jee.feature.feature.group 1.3.2.20110218-0812)
    To: org.eclipse.datatools.modelbase.feature.feature.group 0.0.0
  Cannot satisfy dependency:
    From: Eclipse UI 3.104.0.v20121024-145224 (org.eclipse.ui 3.104.0.v20121024-145224)
    To: bundle org.eclipse.ui.workbench [3.103.0,4.0.0)
  Cannot satisfy dependency:
    From: Eclipse Workbench 3.104.0.v20130204-164612 (org.eclipse.ui.workbench 3.104.0.v20130204-164612)
    To: bundle org.eclipse.e4.ui.model.workbench 0.9.1

 

これの解決法を調べる!